Delayed MMS Delivery

Incident Report for TSG Global

Resolved

This incident is now considered resolved.
Posted Sep 20, 2024 - 13:19 EDT

Monitoring

MMS Delays have been resolved. We are actively monitoring.
Posted Sep 19, 2024 - 19:19 EDT

Investigating

We are actively investigating reports of MMS delayed delivery.
Posted Sep 19, 2024 - 17:52 EDT
This incident affected: Messaging Services (Local Inbound/Outbound MMS, Toll-Free Inbound/Outbound MMS).