Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 18, 2023 - 02:02 EDT
Scheduled
We will be undergoing an emergency database maintenance for the below services. Affected services: portal 10dlc provisioning text protect verified sender forms
Voice and Messaging services ARE NOT AFFECTED.
Posted Jul 17, 2023 - 14:12 EDT
This scheduled maintenance affected: Websites & Portals (TSG Global Main Website) and APIs (LERG / CNAM / LRN).