Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2024 - 04:00 EDT
Scheduled
This maintenance will impact local inbound, toll-free, and voice termination services. During this window, brief interruptions to service are expected as our peering vendor performs necessary updates to their voice stack. We appreciate your understanding and patience during this critical maintenance.
This will not impact messaging services.
Posted Sep 06, 2024 - 14:42 EDT
This scheduled maintenance affected: Voice Services (Toll-Free Inbound Voice, Local Inbound Voice, Voice Termination).