Emergency Maintenance - Messaging/Portal Services

Incident Report for TSG Global

Monitoring

A fix has been implemented for the cluster and we are monitoring for ongoing performance issues. Some applications (such as the customer portal) will require additional diagnostics and monitoring.
Posted Jul 10, 2025 - 18:03 EDT

Investigating

We are attempting to correct ongoing issues related to our Kubernetes cluster and AWS configuration. There will be intermittent downtime as we perform emergency maintenance to restore cluster performance.
Posted Jul 10, 2025 - 16:59 EDT
This incident affects: Websites & Portals (TSG Global Main Website, Customer Portal), APIs (LERG / CNAM / LRN), Messaging Services (SMPP, Local Inbound/Outbound SMS, Toll-Free Inbound/Outbound SMS, Local Inbound/Outbound MMS, Toll-Free Inbound/Outbound MMS), and Upstream Providers (DCAs, MNOs).